Main Menu
Main Page
Forums
New pages
Recent changes
Random page
Help

Glitches
Arbitrary code execution
Pokémon cloning
Pomeg glitch and Glitzer Popping
Tweaking and voiding
Glitches by generation
Glitch categories

References/Resources
Databases
Disassembly projects
The Big HEX List
Pokémon cheat codes
Pokémon glitch terminology
Useful tools
More

Affiliates
Legendary Star Blob 2 (Hakuda) (日本語/Japanese)
Pokémon Speedruns wiki (English)
PRAMA Initiative (Français/French)
MissingNo. Glitch City (Italiano/Italian)
Become an affiliate!

Technical
Site source code

Search Wiki

 

Search Forums

 

Author Topic: Forum Bug List and Reports  (Read 30001 times)

0 Members and 1 Guest are viewing this topic.

Photon-Phoenix

  • Gotta pop dem windows.
  • Head Administrator
  • *****
  • Offline Offline
  • Gender: Male
    • View Profile
Forum Bug List and Reports
« on: August 07, 2011, 10:08:51 pm »
This topic is to be used during the semi-private beta for a list of new bugs and bugs to be squashed/have been squashed.  Please report any bugs you find here.

This is a developing list of bugs that includes theme issues.

  • The bottom of the theme has a weird white table window that doesn't wrap correctly or appears for no reason. fixed 8/7/2011
  • The Administration Panel Header Text is Yellow. fixed 8/7/2011
  • When editing buddies, the following error occurs:
    Wrong value type sent to the database. Array of integers expected. (buddy_list)
    fixed 9/24/2011 - malacoda
  • The moderator notes has a scrollbar from the table cell not being big enough fixed 9/24/2011 - malacoda
  • The Wiki Sidebar in the forum has been Truncated, removing all instances of the é in Pokémon making links broken and making it say "Pokmon" fixed 10/31/2011 - malacoda
  • The Wiki Sidebar has a blank toolbox placed in the wrong area and has two null tables (Search and Languages) fixed 9/24/2011 - malacoda
  • Avatars do not show completely (i.e. Yuzihax's DiscoBrock) on forum posts, although they do in profile. fixed 9/24/2011 - malacoda
  • At the bottom of the forum list, above the "Info Center", the legend for the board icons has wrong images for "No New Posts" and "Redirect Board". fixed 9/24/2011 - malacoda
  • Creating a board spits out this database error:
    Database Error
    Field 'redirect_target' doesn't have a default value
    File: /var/www/glitchcity.info/forums/Sources/Subs-Boards.php
    Line: 787
    fixed 8/15/2011 - malacoda
  • Posted links in dark windows such as this one are harder to see. http://something.com 9/24/2011 - malacoda. NB. I added an underline to all links in posts, because I'm afraid this darker link might be harder to tell from normal text
  • AM/PM doesn't show up next to 12hour time stamps fixed 9/24/2011 - malacoda
  • The Board category text shows up white for guests. fixed 9/24/2011 - malacoda
« Last Edit: October 31, 2011, 10:44:08 am by Adrian Malacoda »

Yuzihax

  • two jimmy carters in a trenchcoat
  • Member+
  • *
  • Offline Offline
  • Gender: Male
  • yee(t)
    • View Profile
Re: Forum Bug List and Reports
« Reply #1 on: August 14, 2011, 03:52:12 pm »
oh lookie here.

links in moved topic messages are missing the "forums.glitchcity.info" in the URLs as it is here

This topic has been moved to Pokémon Discussion.

/index.php?topic=6365.0


Evie the Bird Mother ❤✿

  • Head Administrator
  • *****
  • Offline Offline
  • Gender: Female
    • View Profile
Re: Forum Bug List and Reports
« Reply #2 on: August 14, 2011, 05:28:21 pm »
  • Avatars do not show completely (i.e. Yuzihax's DiscoBrock) on forum posts, although they do in profile.

Update, even though Yuzihax's avatar now shows on forum posts, to clarify other profiles are still affected by the problem, some in their profile page as well e.g. Tombstoner's (I'm assuming you didn't remove your avatar, so if you're reading this please correct me if I'm wrong!).
« Last Edit: August 14, 2011, 05:29:47 pm by Torchickens »

(Image © Sanrio, Nintendo, HAL Laboratory)

I want to be a mother. 🦋 ✿

✿ Hi, I'm Evie. Sex male, and spiritually doesn't believe 'male'/'female' needs to be defined; lives more stereotypically like a woman. Call me whichever pronouns you like. :)

Please note:

While I'm one of the staff who runs the site, Abwayax is the founder and manages the technical side of the site (specifically the server, but I can do forum/wiki stuff if you like, I suggest if you do to make a thread about it to gather a consensus). Still feel free to contact me about higher site issues though; I will forward them to Abwayax if needed. :)

Forgiveness.

I feel that the more people pray to our greatest source/God/mathematical equality for world peace, the more and more it manifests into reality (until our next spiritual death).

Thank you Nyapon for this lovely artwork. :3

Pawny

  • ༼ つ ◕‿◕ ༽つ
  • Member+
  • *
  • Offline Offline
  • Gender: Female
  • I'm sharp! :3
    • View Profile
Re: Forum Bug List and Reports
« Reply #3 on: August 14, 2011, 06:23:35 pm »
Idk if this is wrong or isn't, but when I post, I'm automatically redirected to the board while I should stay in the thread where I posted.
Hug me~!

Photon-Phoenix

  • Gotta pop dem windows.
  • Head Administrator
  • *****
  • Offline Offline
  • Gender: Male
    • View Profile
Re: Forum Bug List and Reports
« Reply #4 on: August 14, 2011, 08:06:19 pm »
That's how SMF works, there might be a setting in your profile you need to change.

Yeah, there is.  Go to profile > change settings > look and layout then check the box that says "return to topic after posting by default."

  • Avatars do not show completely (i.e. Yuzihax's DiscoBrock) on forum posts, although they do in profile.

Update, even though Yuzihax's avatar now shows on forum posts, to clarify other profiles are still affected by the problem, some in their profile page as well e.g. Tombstoner's (I'm assuming you didn't remove your avatar, so if you're reading this please correct me if I'm wrong!).

All old avatars that were uploaded aren't showing up for some reason.  Re-uploading fixes this but not for members who no longer go here.  It's some kind of directory bug I'm guessing. For clairification, the bug I was addressing is that large avatars don't have a scrollbar in posts, and instead get cut off like Yuzi's.
« Last Edit: August 14, 2011, 08:21:07 pm by GARY 'M 9 »

Pawny

  • ༼ つ ◕‿◕ ༽つ
  • Member+
  • *
  • Offline Offline
  • Gender: Female
  • I'm sharp! :3
    • View Profile
Re: Forum Bug List and Reports
« Reply #5 on: August 14, 2011, 08:35:17 pm »
It worked. Thanks. :D
Hug me~!

Abwayax

  • Founder/Technical Support
  • Distinguished Member
  • *
  • Offline Offline
    • View Profile
Re: Forum Bug List and Reports
« Reply #6 on: August 14, 2011, 11:36:57 pm »
I will be upgrading the forum to 2.0 Final sometime this week (its currently still on RC5). Until then I won't be doing bugfixes that require code mods (the buddy list issue looks like one of these). After the upgrade we'll see how many bugs have been fixed.
A. Malacoda, http://monarch-pass.net

Also malacoda@social.monarch-pass.net and @malacoda:matrix.monarch-pass.net

Also adrianmalacoda or kuschelyagi in some places.

Photon-Phoenix

  • Gotta pop dem windows.
  • Head Administrator
  • *****
  • Offline Offline
  • Gender: Male
    • View Profile
Re: Forum Bug List and Reports
« Reply #7 on: August 16, 2011, 04:59:09 pm »
Hmm... AM/PM don't seem to be showing up.

Abwayax

  • Founder/Technical Support
  • Distinguished Member
  • *
  • Offline Offline
    • View Profile
Re: Forum Bug List and Reports
« Reply #8 on: August 19, 2011, 08:24:04 pm »
The forum was upgraded. I'll look into that.
A. Malacoda, http://monarch-pass.net

Also malacoda@social.monarch-pass.net and @malacoda:matrix.monarch-pass.net

Also adrianmalacoda or kuschelyagi in some places.

Photon-Phoenix

  • Gotta pop dem windows.
  • Head Administrator
  • *****
  • Offline Offline
  • Gender: Male
    • View Profile
Re: Forum Bug List and Reports
« Reply #9 on: August 20, 2011, 01:21:19 am »
This error report may help:

8: Undefined index: time_am

8: Undefined index: time_pm

edit: Seems none of the reported bugs were fixed by the upgrade, sadly.
« Last Edit: August 20, 2011, 01:23:05 am by GARY 'M 9 »

eric the espeon

  • Member+
  • Offline Offline
  • CHARIZRAD 'M ROXORX or is it.
    • View Profile
Re: Forum Bug List and Reports
« Reply #10 on: September 07, 2011, 10:22:21 am »
The forum names are extremely hard to read before registration, white on mottled light gray/white is not the best choice. http://i.imgur.com/VLmgC.png

Registration requires no less than five unique questions which almost no one will know without extensive searching (took me quite a while to find, and I know my way around the site roughly, still had to guess one of them), along with a capacha. This is waaaay over the top anti-spambot protection and will prevent almost all casual users from registering. Just the capacha is plenty to stop almost all spambots, maybe keep one much easier unique question if you're really paranoid about spambots. http://i.imgur.com/WHdiS.png

Also, not quite as direct a problem, but having a way to dismiss the large bold paragraph on the forum index about forum rules once you have read them would be really nice. It could be implemented as a dismissable announcement rather than as a permanent redirect forum, making the forum index much less clogged up. Similarly, though it takes up much less space, the link to the main site in the forum index could be removed in favor of making the top-right logo a link to the main page, as most sites do.
« Last Edit: September 07, 2011, 10:29:30 am by eric the espeon »

Photon-Phoenix

  • Gotta pop dem windows.
  • Head Administrator
  • *****
  • Offline Offline
  • Gender: Male
    • View Profile
Re: Forum Bug List and Reports
« Reply #11 on: September 07, 2011, 02:05:31 pm »
Something's wrong with your browser, that text is actually dark grey.  Try forcing a cache refresh (shift+refresh) or updating.

(See attachment)

The number of questions that need answered has been reduced 2 and the questions given will randomize.

Thank you for your input! :)
« Last Edit: September 07, 2011, 02:06:03 pm by GARY 'M 9 »

eric the espeon

  • Member+
  • Offline Offline
  • CHARIZRAD 'M ROXORX or is it.
    • View Profile
Re: Forum Bug List and Reports
« Reply #12 on: September 07, 2011, 02:28:07 pm »
Something's wrong with your browser, that text is actually dark grey.  Try forcing a cache refresh (shift+refresh) or updating.

Quote from: me
The forum names are extremely hard to read before registration, white on mottled light gray/white is not the best choice. http://i.imgur.com/VLmgC.png
It's just that color for people who have not registered, most likely due to them not being able to post/there being no new posts. When I'm logged in I have the same as you, but before the very light/hard to read color is used.

Quote
The number of questions that need answered has been reduced 2 and the questions given will randomize.
Much better, though still maybe a little more than needed in my opinion. It's not like a spambot will get through a single unique question. or even a capatcha most likely.

Quote
Thank you for your input! :)
No prob. Will post more as I find it :)

Photon-Phoenix

  • Gotta pop dem windows.
  • Head Administrator
  • *****
  • Offline Offline
  • Gender: Male
    • View Profile
Re: Forum Bug List and Reports
« Reply #13 on: September 07, 2011, 02:31:57 pm »
Actually, the questions were put up due to mass spambot accounts getting through the high-end (not extreme) captcha.

Abwayax

  • Founder/Technical Support
  • Distinguished Member
  • *
  • Offline Offline
    • View Profile
Re: Forum Bug List and Reports
« Reply #14 on: September 24, 2011, 07:30:02 pm »
Those category names should not be white. I will look into that.

Good idea about the rules reminder text by the way.
A. Malacoda, http://monarch-pass.net

Also malacoda@social.monarch-pass.net and @malacoda:matrix.monarch-pass.net

Also adrianmalacoda or kuschelyagi in some places.