Main Menu
Main Page
Recent changes
Random page


Major Glitches
Trainer escape glitch
Old man trick
Celebi Egg trick
Select glitches (Japan)
SRAM glitch
CoolTrainer♀ corruption
LOL glitch
Rival LOL glitch
Super Glitch
ZZAZZ glitch
Pomeg data corruption glitch (Glitzer Popping)
Elite Four door glitch (Japan)
Pokémon merge glitch
Pokémon cloning
Time Capsule exploit
Arbitrary code execution
Coin Case glitches

Other Glitch Categories
Glitches by generation
Glitches between two generations
Japan-only/language specific glitches
Music glitches
Natural glitches
Non-core series glitches
Non-Pokémon glitches
Officially acknowledged glitches
Recurring glitches
Dead glitches

Pokémon GameShark codes
The Big HEX List
Glitch Pokémon cries
GB programming
Debugging features
Easter eggs
Error traps
Glitch areas
Glitch myths
Non-glitch exploits
Placeholder texts
Pokémon glitch terminology
Unused content and prerelease information

Useful Tools
8F Helper
GBz80 to Items
Old man trick name generator
PATH (Prama's Advanced Tweaking Heaven)
Save file editors
Special stat/Pokémon converter
Trainer escape Trainer Pokémon finder

Legendary Star Blob 2 (Hakuda)
Pokémon Speedruns wiki
PRAMA Initiative
Become an affiliate!

Site Source Code

Search Wiki


Search Forums


Author Topic: Brock Through Walls not working...or at least, barely  (Read 243 times)

0 Members and 1 Guest are viewing this topic.


  • GCLF Member
  • Offline Offline
    • View Profile
Brock Through Walls not working...or at least, barely
« on: September 30, 2017, 12:41:09 pm »
Hi, I'm very new, just joined to ask this question!

So some backstory: I've been having a good time playing Pokemon Gold on VC, but after raising a Growlithe the whole game, I only recently realized that you need to beat the Johto E4 and make it to Kanto before you can get a Fire Stone!! I didn't want to wait that long, so I decided I would make it to Celadon in my Pokemon Blue game, buy the Fire Stone, trade the Growlithe over, evolve it, and trade it back. Very convoluted, but it would work. Instead of playing through the game like a normal person I decided to utilize Brock Through Walls to make it to Celadon. Fire Stones are quite cheap so I figured I could just go over there, buy a Fire Stone, and be done with it in under half an hour.

It took a lot of tries, but I finally managed to get a Level 8 Bulbasaur with 16 Spc and a Level 4 Pidgey with 15/18 HP. The Bulbasaur has 26/27 HP, and its PP is all over the place, but I figured the Bulbasaur + Pidgey would be enough and I didn't need to worry about PP. Good news: The glitch technically works. I can move wherever I want.

Bad news: For some reason, the menu will not stop popping up if I stop moving for even a moment. Even worse, every step downwards is a battle; the game often just endlessly opens up my menu, or forces me in some other direction. I can move upwards or to the right just fine, but the game seems to hate moving the player down. I've tried canceling the menus, but they're endless. I've tried sitting back and seeing where the game will take me, but that ends up crashing the game or ending the glitch. Through a lot of finagling I can make it to Cerulean City, but sometimes the glitch just ends there for what seems like no reason; I haven't entered any doors or anything. As such, I can't walk over the Saffron gate and over to Celadon. This is especially frustrating because I don't know the path to Celadon by heart, so needing to be constantly moving in an upwards or right direction when there's doors and out-of-bounds areas everywhere can get annoying.

Does anyone know what's happening that makes the glitch so frustrating to work with? Is it because my Pidgey has a total HP of 18? I'd really like to figure this out because I already wasted 2 hours just trying to evolve my Growlithe that isn't even in this game :(
« Last Edit: September 30, 2017, 01:21:32 pm by Gummysaur »


  • The French Lord of Laziness (and a huge The Legend Of Zelda fan)
  • Distinguished Member
  • *
  • Offline Offline
  • Gender: Male
  • Pewter City (B)rocks !
    • View Profile
    • My Little Website
Re: Brock Through Walls not working...or at least, barely
« Reply #1 on: October 01, 2017, 10:35:27 am »
Keep holding B. That should solve the whole problem.
This is an issue inherent to Brock Through Walls. It's a bit technical, but the game is constantly trying to force some inputs, but as long as you hold a button you're preventing this from happening. Holding B does nothing yet still prevents the input forcing.
"THOU SHALL NOT PASS !!"  RIVAL's effect, Gandalf.

Proudly glitching Pokémon Red and Yellow on a Black & White GB, Pocket GB, GB Color, GBA SP and new 3DS.

My Twitter (beware, I'm French)
My YouTube (same warning)

Here is an online tool to build 8F setups : GBz80 to Items !

They see me layzin', they ha-tin'...
Heavy contributor of the global augmentation of entropy (my room's is too damn high !)


  • GCLF Member
  • Offline Offline
    • View Profile
Re: Brock Through Walls not working...or at least, barely
« Reply #2 on: October 01, 2017, 12:06:08 pm »
Oh wow, it's that simple? That's simultaneously a relief but also kind of embarrassing ^^u

Thank you very much, my Growlithe is now an Arcanine and is no longer dying to everything! I picked up a Reflect and Submission TM on the way as well :D